I can no longer log in to the chatbot

Hi,

I can no longer log in to the chatbot. I always get the message Insufficient permission.

Insufficient permission

In the log are the following errors:

2022-03-13T13:09:17.154 !!! ERROR !!! Access token of broadcaster was not refreshed.
2022-03-13T13:09:17.160 | CURRENCY: Fetched rates
2022-03-13T13:09:17.193 !!! ERROR !!! Access token of broadcaster was not refreshed.
2022-03-13T13:09:17.202 !!! ERROR !!! Possibly Unhandled Rejection at: Promise {
  <rejected> Error: Request failed with status code 403
      at createError (/app/node_modules/axios/lib/core/createError.js:16:15)
      at settle (/app/node_modules/axios/lib/core/settle.js:17:12)
      at IncomingMessage.handleStreamEnd (/app/node_modules/axios/lib/adapters/http.js:293:11)
      at IncomingMessage.emit (node:events:532:35)
      at endReadableNT (node:internal/streams/readable:1346:12)
      at processTicksAndRejections (node:internal/process/task_queues:83:21) {
    config: {
      transitional: [Object],
      adapter: [Function: httpAdapter],
      transformRequest: [Array],
      transformResponse: [Array],
      timeout: 0,
      xsrfCookieName: 'XSRF-TOKEN',
      xsrfHeaderName: 'X-XSRF-TOKEN',
      maxContentLength: -1,
      maxBodyLength: -1,
      validateStatus: [Function: validateStatus],
      headers: [Object],
      method: 'post',
      url: 'https://twitch-token-generator.soge.workers.dev/refresh/f9inswa7vscdwdck8g0m0405eegytd3u41a9yx4grw8',
      data: undefined
    },
    request: ClientRequest {
      _events: [Object: null prototype],
      _eventsCount: 7,
      _maxListeners: undefined,
      outputData: [],
      outputSize: 0,
      writable: true,
      destroyed: false,
      _last: true,
      chunkedEncoding: false,
      shouldKeepAlive: false,
      maxRequestsOnConnectionReached: false,
      _defaultKeepAlive: true,
      useChunkedEncodingByDefault: true,
      sendDate: false,
      _removedConnection: false,
      _removedContLen: false,
      _removedTE: false,
      _contentLength: 0,
      _hasBody: true,
      _trailer: '',
      finished: true,
      _headerSent: true,
      _closed: false,
      socket: [TLSSocket],
      _header: 'POST /refresh/f9inswa7vscdwdck8g0m0405eegytd3u41a9yx4grw8 HTTP/1.1\r\n' +
        'Accept: application/json, text/plain, */*\r\n' +
        'Content-Type: application/x-www-form-urlencoded\r\n' +
        'SogeBot-Channel: \r\n' +
        'SogeBot-Owners: methones, \r\n' +
        'User-Agent: axios/0.24.0\r\n' +
        'Host: twitch-token-generator.soge.workers.dev\r\n' +
        'Connection: close\r\n' +
        'Content-Length: 0\r\n' +
        '\r\n',
      _keepAliveTimeout: 0,
      _onPendingData: [Function: nop],
      agent: [Agent],
      socketPath: undefined,
      method: 'POST',
      maxHeaderSize: undefined,
      insecureHTTPParser: undefined,
      path: '/refresh/f9inswa7vscdwdck8g0m0405eegytd3u41a9yx4grw8',
      _ended: true,
      res: [IncomingMessage],
      aborted: false,
      timeoutCb: null,
      upgradeOrConnect: false,
      parser: null,
      maxHeadersCount: null,
      reusedSocket: false,
      host: 'twitch-token-generator.soge.workers.dev',
      protocol: 'https:',
      _redirectable: [Writable],
      [Symbol(kCapture)]: false,
      [Symbol(kNeedDrain)]: false,
      [Symbol(corked)]: 0,
      [Symbol(kOutHeaders)]: [Object: null prototype]
    },
    response: {
      status: 403,
      statusText: 'Forbidden',
      headers: [Object],
      config: [Object],
      request: [ClientRequest],
      data: [Object]
    },
    isAxiosError: true,
    toJSON: [Function: toJSON]
  }
} 
reason: Error: Request failed with status code 403

Your refresh token is invalid. But that should not affect your login, restart bot and try in incognito mode.

I had already restarted the server before the post, but for whatever reason it is working again now.
Thank you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.