Spotify Playlist Return

Expected behavior

Spotify should return to playlist and continue to next track after request queue has been cleared.

Actual behavior

Spotify stops playing bot errors out with

2020-04-07T22:58:45.782 |! Cannot continue playlist from spotify:track:1qqeqeRgn7DFn1LSOA9VBv
2020-04-07T22:58:45.785 |! Playlist will continue from random track
2020-04-07T22:58:46.360 |! Cannot continue playlist from null

Steps to reproduce

Change playlist link disabled Spotify then reauthenticated.

Additional informations

2020-04-07T23:03:52.950 <<< !_debug [reesey275]
2020-04-07T23:03:53.819 DEBUG: * ======= COPY DEBUG MESSAGE FROM HERE =======
2020-04-07T23:03:53.824 DEBUG: * GENERAL | OS: npm/6.14.4 node/v12.16.1 linux x64
2020-04-07T23:03:54.112 DEBUG: * | Bot version: 10.14.1
2020-04-07T23:03:54.114 DEBUG: * | DB: mysql
2020-04-07T23:03:54.115 DEBUG: * | HEAP: 68.78 MB
2020-04-07T23:03:54.159 DEBUG: * | Uptime: 08:20:26
2020-04-07T23:03:54.161 DEBUG: * | Language: en
2020-04-07T23:03:54.164 DEBUG: * | Mute: false
2020-04-07T23:03:54.166 DEBUG: * SYSTEMS | Songs, Highlights, Points, Alias, Bets, Checklist, Commercial, Ranks, CustomCommands, Cooldown, HowLongToBeat, Keywords, Moderation, Polls, Price, Queue, Quotes, Raffles, Scrim,
Timers, Top, UserInfo
2020-04-07T23:03:54.167 DEBUG: * GAMES | Duel, FightMe, Gamble, Heist, Roulette, -Seppuku
2020-04-07T23:03:54.167 DEBUG: * INTEGRATIONS | Spotify, -Donationalerts, -PhillipsHue, -Qiwi, -ResponsiveVoice,
-StreamElements, -Streamlabs, -TipeeeStream, Twitter
2020-04-07T23:03:54.168 DEBUG: * WIDGETS | commercial, customvariables, join, soundboard, social, cmdboard,
eventlist, chat, twitch, spotify, bets
2020-04-07T23:03:54.169 DEBUG: * OAUTH | BOT true | BROADCASTER true
2020-04-07T23:03:54.169 DEBUG: * ======= END OF DEBUG MESSAGE =======

Thanks, will check

I cannot reproduce this issue 100%. Can you please test this fix and let me know if it is fixed or if you have additional errors.

5afe63979cd9d32029917c8c60e88beb337e40fe spotify.js (48.4 KB)

Copy this file to /path/to/bot/dest/integrations/spotify.js and restart a bot

Edit: Sorry I attached wrong file, this should be OK
Edit2: Yeah, this one for sure :man_facepalming:

Unable to access the file.

https://community.sogebot.xyz/uploads/short-url/cYXZTzzcRYb2D7chXGLJ7rkUoWO.js

Yeah, seems like file upload of js files is broken in discourse.

https://pastebin.com/raw/WGXWMvsf

You can copy content of this pastebin into your /dest/integrations/spotify.js

That appears to have corrected the issue. Does it matter if you use the Spotify URL or URI? I was using the URL and that was causing the problem. When I uploaded the new js code it was still causing the same issue. But I switched to the spotify URI and it goes to the playlist now. Testing everything and may have found a new problem but will test a bit more before reporting.

uri should be used

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.